Friday, August 10, 2007

AIPS Binary Downloads

Oh my god. Installing software on my new mac makes me feel like a complete idiot.

There are all these detailed websites about how to install aips on your mac, but NONE (not one!) of them link to the actualy binaries! Many of them mention that said binaries exist. I think they are available by ftp. Ftp to what, though, i ask you? Does anybody know how to download the aips binaries so i can get on with this installation nightmare?


emily said...

just download the script and do this:

Make sure that the file is executable. Then, for text installations, run the script with the command
or, for binary installations,
perl -n

which is from this page. this other page might be helpful as well.

amanda said...

The special macintosh instructions of kind of old. If you don't have X11 installed, you can install it from the DVDs that came with your system. (I think it's the second non-OS DVD and you need to choose custom install and check off the X11 boxes.)

amanda said...

Here's some notes from setting up my new laptop.

!) Make sure you have X11 and Xcode tools. You'll probably already have this if you setup macports (highly recommended if you want unix programs). If not, put in the DVD (#2 I think) that came with your computer and do an custom install that includes X11. You don't need to do a complete reinstall of OS X. To get Xcode tools, sign up with ADC (Apple Developer Connection) and download the disk image and follow the instructions.

2) I already had rsync and cvs on my computer. (Check using where rsync and where cvs on the command line.) If not, get from macports.

3) Download from the AIPS site. Put it in a directory called aips and make it executable 'chmod u+x'. Then run the installer using the command ' -n' to do the binary install. It's much easier than compiling the whole thing.

4) Follow the instructions in the aips install wizard and then add the relevant services at /etc/services as instructed in the AIPS Macintosh instructions.

5) Ta-dah it works!

Anonymous said...

I followed all the steps and installed AIPS successfully in my Mac OS X!!
However, I have it installed in /Users/username but I would like to have it in an 'aips' folder.
I have tried to create an 'aips' folder and move all the aips-related files to /Users/username/aips/. I have modified the setenv in AIPSPATH.CSH and LOGIN.CSH accordingly.
But then AIPS doesn't work.
Do you know if it's possible to move AIPS to this other directory or should I install it again?

amanda said...

It's probably simplest to nuke the entire original install and try again.

Anonymous said...

Thank you! I managed to install it in the /aips directory I created.
However, when running AIPS, I get this message:

DADEVS.PL: This program is untested under Perl version 5.010
(Using global default file /Users/mmezcua/aips/DA00/DADEVS.LIST for DADEVS.PL)
UNIXSERVERS: Start TV LOCK daemon TVSRV1 on localhost
/Users/mmezcua/aips/31DEC11/SYSTEM/UNIX/UNIXSERVERS: line 172: NEWEST: command not found
/Users/mmezcua/aips/31DEC11/SYSTEM/UNIX/UNIXSERVERS: line 172: [: =: unary operator expected

I have tried modifying the UNIXSERVERS file but nothing works.
Do you know what's wrong?